087a2bc16c
SVN-Revision: 14013
11 lines
613 B
Diff
11 lines
613 B
Diff
--- a/libpthread/linuxthreads/Makefile.in
|
|
+++ b/libpthread/linuxthreads/Makefile.in
|
|
@@ -65,7 +65,7 @@ CFLAGS-OMIT-libc_pthread_init.c := $(CFL
|
|
libpthread_libc_CSRC := \
|
|
forward.c libc-cancellation.c libc_pthread_init.c # alloca_cutoff.c
|
|
libpthread_libc_OBJ := $(patsubst %.c, $(libpthread_OUT)/%.o,$(libpthread_libc_CSRC))
|
|
-libc-static-y += $(libpthread_OUT)/libc_pthread_init.o
|
|
+libc-static-y += $(libpthread_OUT)/libc_pthread_init.o $(libpthread_OUT)/libc-cancellation.o
|
|
libc-shared-y += $(libpthread_libc_OBJ:.o=.oS)
|
|
|
|
libpthread-static-y += $(patsubst %,$(libpthread_OUT)/%.o,$(libpthread_static_SRC))
|