7e6c53dac9
Support for MIPS toolchains without FPU support was added upstream, so remove our patch. patches/310-mips-link-tool.patch was a backport form this version of valgrind src/abort.c is not referenced anywhere Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
45 lines
1.6 KiB
Diff
45 lines
1.6 KiB
Diff
--- a/coregrind/vg_preloaded.c
|
|
+++ b/coregrind/vg_preloaded.c
|
|
@@ -57,7 +57,7 @@
|
|
void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run);
|
|
void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run)
|
|
{
|
|
-# if !defined(__UCLIBC__) \
|
|
+# if !defined(__UCLIBC__) && defined(__GLIBC__) \
|
|
&& !defined(VGPV_arm_linux_android) \
|
|
&& !defined(VGPV_x86_linux_android) \
|
|
&& !defined(VGPV_mips32_linux_android) \
|
|
--- a/include/pub_tool_redir.h
|
|
+++ b/include/pub_tool_redir.h
|
|
@@ -243,7 +243,7 @@
|
|
/* --- Soname of the standard C library. --- */
|
|
|
|
#if defined(VGO_linux) || defined(VGO_solaris)
|
|
-# define VG_Z_LIBC_SONAME libcZdsoZa // libc.so*
|
|
+# define VG_Z_LIBC_SONAME libcZdZa // libc.*
|
|
|
|
#elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
|
|
# define VG_Z_LIBC_SONAME libSystemZdZaZddylib // libSystem.*.dylib
|
|
@@ -275,7 +275,11 @@
|
|
/* --- Soname of the pthreads library. --- */
|
|
|
|
#if defined(VGO_linux)
|
|
+# if defined(__GLIBC__) || defined(__UCLIBC__)
|
|
# define VG_Z_LIBPTHREAD_SONAME libpthreadZdsoZd0 // libpthread.so.0
|
|
+# else
|
|
+# define VG_Z_LIBPTHREAD_SONAME libcZdZa // libc.*
|
|
+# endif
|
|
#elif defined(VGO_darwin)
|
|
# define VG_Z_LIBPTHREAD_SONAME libSystemZdZaZddylib // libSystem.*.dylib
|
|
#elif defined(VGO_solaris)
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1047,8 +1047,6 @@ case "${GLIBC_VERSION}" in
|
|
;;
|
|
2.0|2.1|*)
|
|
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
|
|
- AC_MSG_ERROR([Valgrind requires glibc version 2.2 or later,])
|
|
- AC_MSG_ERROR([Darwin libc, Bionic libc or Solaris libc])
|
|
;;
|
|
esac
|
|
|