054f3fd57b
OpenWrt uses ancient u-boot thats not reproducible. There are multiple upstream changes that introduce reproducible builds like: 859e92b775fd8ebcfacc591eaf621b677c95b6f7 (not used here - the CMD_DATE/TIMESTAMP functionality seems to be disabled by config) 70d39f57146a6cb94736db39c770c3d95e07bedb f3f431a712729a1af94d01bd1bfde17a252ff02c 2d9efa1227262249d381ed5d9d341cbdba76e62d Instead of changing the Makefile too much this changeset just tries to use the changes in Makefile from current upstream git f5fd45f *Should* fix issue reported by reproducible lede page: https://tests.reproducible-builds.org/lede/lede.html Compile tested only (verified w. hexdump & md5sum) Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
26 lines
999 B
Diff
26 lines
999 B
Diff
--- a/cpu/mips/Makefile
|
|
+++ b/cpu/mips/Makefile
|
|
@@ -33,6 +33,7 @@ SOBJS-$(CONFIG_INCA_IP) += incaip_wdt.o
|
|
COBJS-$(CONFIG_INCA_IP) += asc_serial.o incaip_clock.o
|
|
COBJS-$(CONFIG_PURPLE) += asc_serial.o
|
|
COBJS-$(CONFIG_SOC_AU1X00) += au1x00_eth.o au1x00_serial.o au1x00_usb_ohci.o
|
|
+COBJS-$(CONFIG_AR71XX) += ar71xx_serial.o
|
|
|
|
SRCS := $(START:.o=.S) $(SOBJS-y:.o=.S) $(COBJS-y:.o=.c)
|
|
OBJS := $(addprefix $(obj),$(SOBJS-y) $(COBJS-y))
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -3474,6 +3474,13 @@ qemu_mips_config : unconfig
|
|
@$(MKCONFIG) -a qemu-mips mips mips qemu-mips
|
|
|
|
#########################################################################
|
|
+## MIPS32 AR71XX (24K)
|
|
+#########################################################################
|
|
+
|
|
+nbg460n_550n_550nh_config : unconfig
|
|
+ @$(MKCONFIG) -a nbg460n mips mips nbg460n zyxel
|
|
+
|
|
+#########################################################################
|
|
## MIPS64 5Kc
|
|
#########################################################################
|
|
|