dab5a44067
n As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
40 lines
1.5 KiB
Diff
40 lines
1.5 KiB
Diff
From ce348644b8dc5384764ed3fb91592d62523cbcb3 Mon Sep 17 00:00:00 2001
|
||
From: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
|
||
Date: Fri, 4 Nov 2016 19:39:38 +0100
|
||
Subject: [PATCH] kbuild: add -fno-PIE
|
||
MIME-Version: 1.0
|
||
Content-Type: text/plain; charset=UTF-8
|
||
Content-Transfer-Encoding: 8bit
|
||
|
||
commit 8ae94224c9d72fc4d9aaac93b2d7833cf46d7141 upstream.
|
||
|
||
Debian started to build the gcc with -fPIE by default so the kernel
|
||
build ends before it starts properly with:
|
||
|kernel/bounds.c:1:0: error: code model kernel does not support PIC mode
|
||
|
||
Also add to KBUILD_AFLAGS due to:
|
||
|
||
|gcc -Wp,-MD,arch/x86/entry/vdso/vdso32/.note.o.d … -mfentry -DCC_USING_FENTRY … vdso/vdso32/note.S
|
||
|arch/x86/entry/vdso/vdso32/note.S:1:0: sorry, unimplemented: -mfentry isn’t supported for 32-bit in combination with -fpic
|
||
|
||
Tagging it stable so it is possible to compile recent stable kernels as
|
||
well.
|
||
|
||
Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
|
||
Signed-off-by: Michal Marek <mmarek@suse.com>
|
||
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
||
---
|
||
Makefile | 2 ++
|
||
1 file changed, 2 insertions(+)
|
||
|
||
--- a/Makefile
|
||
+++ b/Makefile
|
||
@@ -619,6 +619,8 @@ include arch/$(SRCARCH)/Makefile
|
||
KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
|
||
KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,)
|
||
KBUILD_CFLAGS += $(call cc-disable-warning,frame-address,)
|
||
+KBUILD_CFLAGS += $(call cc-option,-fno-PIE)
|
||
+KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
|
||
|
||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||
KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
|