openwrtv3/target/linux/brcm2708/patches-4.4/0188-BCM270X_DT-Build-and-document-the-wittypi-overlay.patch
Álvaro Fernández Rojas dab5a44067 brcm2708: update linux 4.4 patches to latest version
n
As usual these patches were extracted and rebased from the raspberry pi repo:
https://github.com/raspberrypi/linux/tree/rpi-4.4.y

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
2017-02-06 22:24:42 +01:00

50 lines
1.7 KiB
Diff

From b4d870dddb6127a762d67530b80658ba8adccbfb Mon Sep 17 00:00:00 2001
From: Phil Elwell <phil@raspberrypi.org>
Date: Tue, 15 Mar 2016 16:41:37 +0000
Subject: [PATCH] BCM270X_DT: Build and document the wittypi overlay
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
---
arch/arm/boot/dts/overlays/Makefile | 1 +
arch/arm/boot/dts/overlays/README | 8 ++++++++
arch/arm/boot/dts/overlays/wittypi-overlay.dts | 2 +-
3 files changed, 10 insertions(+), 1 deletion(-)
--- a/arch/arm/boot/dts/overlays/Makefile
+++ b/arch/arm/boot/dts/overlays/Makefile
@@ -74,6 +74,7 @@ dtbo-$(RPI_DT_OVERLAYS) += vc4-kms-v3d.d
dtbo-$(RPI_DT_OVERLAYS) += vga666.dtbo
dtbo-$(RPI_DT_OVERLAYS) += w1-gpio.dtbo
dtbo-$(RPI_DT_OVERLAYS) += w1-gpio-pullup.dtbo
+dtbo-$(RPI_DT_OVERLAYS) += wittypi.dtbo
targets += dtbs dtbs_install
targets += $(dtbo-y)
--- a/arch/arm/boot/dts/overlays/README
+++ b/arch/arm/boot/dts/overlays/README
@@ -920,6 +920,14 @@ Params: gpiopin GPIO for
extpullup GPIO for external pullup (default "5")
+Name: wittypi
+Info: Configures the wittypi RTC module.
+Load: dtoverlay=wittypi,<param>=<val>
+Params: led_gpio GPIO for LED (default "17")
+ led_trigger Choose which activity the LED tracks (default
+ "default-on")
+
+
Troubleshooting
===============
--- a/arch/arm/boot/dts/overlays/wittypi-overlay.dts
+++ b/arch/arm/boot/dts/overlays/wittypi-overlay.dts
@@ -37,7 +37,7 @@
};
__overrides__ {
- led_gpio = <&wittypi_led>,"gpios:4";
+ led_gpio = <&wittypi_led>,"gpios:4";
led_trigger = <&wittypi_led>,"linux,default-trigger";
};