e553dfc356
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
23 lines
910 B
Diff
23 lines
910 B
Diff
Index: linux-3.14.18/drivers/pci/host/Kconfig
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/pci/host/Kconfig
|
|
+++ linux-3.14.18/drivers/pci/host/Kconfig
|
|
@@ -33,4 +33,9 @@ config PCI_RCAR_GEN2
|
|
There are 3 internal PCI controllers available with a single
|
|
built-in EHCI/OHCI host controller present on each one.
|
|
|
|
+config PCI_OXNAS
|
|
+ bool "PLX Oxnas PCIe controller"
|
|
+ depends on ARCH_OXNAS
|
|
+ select PCIEPORTBUS
|
|
+
|
|
endmenu
|
|
Index: linux-3.14.18/drivers/pci/host/Makefile
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/pci/host/Makefile
|
|
+++ linux-3.14.18/drivers/pci/host/Makefile
|
|
@@ -4,3 +4,4 @@ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
|
|
obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
|
|
obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
|
|
obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
|
|
+obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
|