baad22eed3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
35 lines
1.4 KiB
Diff
35 lines
1.4 KiB
Diff
From b78e78fa375e3aa1e91b35030e8dfc930ba425f2 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Thu, 9 Feb 2017 14:36:44 +0000
|
|
Subject: [PATCH] sound: Demote deferral errors to INFO level
|
|
|
|
At present there is no mechanism to specify driver load order,
|
|
which can lead to deferrals and repeated retries until successful.
|
|
Since this situation is expected, reduce the dmesg level to
|
|
INFO and mention that the operation will be retried.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
sound/soc/soc-core.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/sound/soc/soc-core.c
|
|
+++ b/sound/soc/soc-core.c
|
|
@@ -1013,7 +1013,7 @@ static int soc_bind_dai_link(struct snd_
|
|
cpu_dai_component.dai_name = dai_link->cpu_dai_name;
|
|
rtd->cpu_dai = snd_soc_find_dai(&cpu_dai_component);
|
|
if (!rtd->cpu_dai) {
|
|
- dev_err(card->dev, "ASoC: CPU DAI %s not registered\n",
|
|
+ dev_info(card->dev, "ASoC: CPU DAI %s not registered - will retry\n",
|
|
dai_link->cpu_dai_name);
|
|
goto _err_defer;
|
|
}
|
|
@@ -1025,7 +1025,7 @@ static int soc_bind_dai_link(struct snd_
|
|
for (i = 0; i < rtd->num_codecs; i++) {
|
|
codec_dais[i] = snd_soc_find_dai(&codecs[i]);
|
|
if (!codec_dais[i]) {
|
|
- dev_err(card->dev, "ASoC: CODEC DAI %s not registered\n",
|
|
+ dev_info(card->dev, "ASoC: CODEC DAI %s not registered - will retry\n",
|
|
codecs[i].dai_name);
|
|
goto _err_defer;
|
|
}
|