openwrtv3/target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch
Florian Fainelli dd4ee63fa4 mcs814x: add 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org>

SVN-Revision: 43926
2015-01-10 20:12:02 +00:00

20 lines
677 B
Diff

--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -157,6 +157,10 @@ config MICREL_PHY
---help---
Currently has a driver for the KSZ8041
+config MCS814X_PHY
+ tristate "Driver for the Moschip MCS814x internal PHY"
+ depends on ARCH_MCS814X
+
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -49,3 +49,4 @@ obj-$(CONFIG_MDIO_BUS_MUX_GPIO) += mdio-
obj-$(CONFIG_MDIO_BUS_MUX_MMIOREG) += mdio-mux-mmioreg.o
obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o
obj-$(CONFIG_MDIO_MOXART) += mdio-moxart.o
+obj-$(CONFIG_MCS814X_PHY) += mcs814x.o