97b14fd700
This brings curl to version 7.43.0 and contains fixes for the following security vulnerabilities: CVE-2015-3236: lingering HTTP credentials in connection re-use http://curl.haxx.se/docs/adv_20150617A.html CVE-2015-3237: SMB send off unrelated memory contents http://curl.haxx.se/docs/adv_20150617B.html The 100-check_long_long patch is not needed any more, because the upstream autoconf script already checks for long long when cyassl is selected. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 46169
22 lines
679 B
Diff
22 lines
679 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -129,7 +129,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
bin_SCRIPTS = curl-config
|
|
|
|
SUBDIRS = lib src include
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -577,7 +577,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
|
|
bin_SCRIPTS = curl-config
|
|
SUBDIRS = lib src include
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
LIB_VTLS_CFILES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c \
|