68150d3125
Several changes has been made: + AES support has been removed by upstream commit c6831c7 (2017-11-14) [remove patch "200-fw_env_no_aes.patch"] + Support for UBI volumes has beed added by upstream commit 34255b9 (2017-11-15) [remove patch "300-support-env-in-ubivol-chardev.patch"] + A command line argument has beed added ("-c") to manually indicate the location of the environment configuration file Also, patch "400-u-boot-2015.10-stdint.patch" is no longer necessary, and the config option to enable UBI support has been removed. Size comparisons: fw_printenv size: Target Before After ar71xx 15,189 bytes 18,133 bytes (+2,944 bytes) ipq40xx 20,873 bytes 20,987 bytes (+114 bytes) mvebu 20,881 bytes 20,991 bytes (+110 bytes) ramips 15,128 bytes 18,072 bytes (+2,944 bytes) OPKG package size: Target Before After ar71xx 11,309 bytes 12,875 bytes (+1,566 bytes) ipq40xx 11,772 bytes 13,299 bytes (+1,527 bytes) mvebu 11,609 bytes 13,114 bytes (+1,505 bytes) ramips 10,975 bytes 12,503 bytes (+1,528 bytes) Compile tested: ipq40xx (musl, glibc, gcc5-musl), ar71xx, mvebu, ramips Run tested: ipq40xx (ASUS RT-AC58U) Signed-off-by: Luis Araneda <luaraneda@gmail.com>
13 lines
404 B
Diff
13 lines
404 B
Diff
--- a/tools/env/Makefile
|
|
+++ b/tools/env/Makefile
|
|
@@ -10,6 +10,10 @@
|
|
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
|
|
override HOSTCC = $(CC)
|
|
|
|
+ifneq ($(TARGET_CFLAGS),)
|
|
+HOSTCFLAGS = $(TARGET_CFLAGS)
|
|
+endif
|
|
+
|
|
# Compile for a hosted environment on the target
|
|
HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
|
|
-idirafter $(srctree)/tools/env \
|