openwrtv3/target/linux/generic/patches-3.12/202-reduce_module_size.patch
Imre Kaloz e72c7e17a4 preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>

SVN-Revision: 38528
2013-10-24 13:50:11 +00:00

11 lines
487 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -379,7 +379,7 @@ KBUILD_CFLAGS_KERNEL :=
KBUILD_AFLAGS := -D__ASSEMBLY__
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)