9a26a9e8b9
The device tree files are now matching the kernel 4.17 and this will be send also for integration into mainline U-Boot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
222 lines
5 KiB
Diff
222 lines
5 KiB
Diff
From fd576a3c594ee2356b50a0738403e5cef094935a Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Sat, 9 Jun 2018 15:16:42 +0200
|
|
Subject: sun50i: h5: Add initial Orange Pi Zero Plus support
|
|
|
|
Orange Pi Zero Plus is an open-source single-board computer
|
|
using the Allwinner H5 SOC.
|
|
|
|
H5 Orangepi Zero Plus has
|
|
- Quad-core Cortex-A53
|
|
- 512MB DDR3
|
|
- micrSD slot
|
|
- 16MBit SPI Nor flash
|
|
- Debug TTL UART
|
|
- 1GBit/s Ethernet (RTL8211E)
|
|
- Wifi (RTL8189FTV)
|
|
- USB 2.0 Host
|
|
- USB 2.0 OTG + power supply
|
|
|
|
The device tree file is copied from the Linux kernel 4.18.
|
|
|
|
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|
---
|
|
arch/arm/dts/Makefile | 1 +
|
|
arch/arm/dts/sun50i-h5-orangepi-zero-plus.dts | 145 ++++++++++++++++++++++++++
|
|
board/sunxi/MAINTAINERS | 5 +
|
|
configs/orangepi_zero_plus_defconfig | 16 +++
|
|
4 files changed, 167 insertions(+)
|
|
create mode 100644 arch/arm/dts/sun50i-h5-orangepi-zero-plus.dts
|
|
create mode 100644 configs/orangepi_zero_plus_defconfig
|
|
|
|
--- a/arch/arm/dts/Makefile
|
|
+++ b/arch/arm/dts/Makefile
|
|
@@ -372,6 +372,7 @@ dtb-$(CONFIG_MACH_SUN8I_V3S) += \
|
|
dtb-$(CONFIG_MACH_SUN50I_H5) += \
|
|
sun50i-h5-nanopi-neo2.dtb \
|
|
sun50i-h5-nanopi-neo-plus2.dtb \
|
|
+ sun50i-h5-orangepi-zero-plus.dtb \
|
|
sun50i-h5-orangepi-pc2.dtb \
|
|
sun50i-h5-orangepi-prime.dtb \
|
|
sun50i-h5-orangepi-zero-plus2.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm/dts/sun50i-h5-orangepi-zero-plus.dts
|
|
@@ -0,0 +1,145 @@
|
|
+/*
|
|
+ * Copyright (C) 2016 ARM Ltd.
|
|
+ * Copyright (C) 2018 Hauke Mehrtens <hauke@hauke-m.de>
|
|
+ *
|
|
+ * SPDX-License-Identifier: (GPL-2.0+ OR X11)
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "sun50i-h5.dtsi"
|
|
+
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/input/input.h>
|
|
+#include <dt-bindings/pinctrl/sun4i-a10.h>
|
|
+
|
|
+/ {
|
|
+ model = "Xunlong Orange Pi Zero Plus";
|
|
+ compatible = "xunlong,orangepi-zero-plus", "allwinner,sun50i-h5";
|
|
+
|
|
+ reg_vcc3v3: vcc3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vcc3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ };
|
|
+
|
|
+ aliases {
|
|
+ ethernet0 = &emac;
|
|
+ ethernet1 = &rtl8189ftv;
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ pwr {
|
|
+ label = "orangepi:green:pwr";
|
|
+ gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>; /* PA10 */
|
|
+ default-state = "on";
|
|
+ };
|
|
+
|
|
+ status {
|
|
+ label = "orangepi:red:status";
|
|
+ gpios = <&pio 0 17 GPIO_ACTIVE_HIGH>; /* PA17 */
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <100000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 3 6 GPIO_ACTIVE_HIGH>; /* PD6 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&ehci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ehci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&emac_rgmii_pins>;
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ phy-handle = <&ext_rgmii_phy>;
|
|
+ phy-mode = "rgmii";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&external_mdio {
|
|
+ ext_rgmii_phy: ethernet-phy@1 {
|
|
+ compatible = "ethernet-phy-ieee802.3-c22";
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc0 {
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&pio 5 6 GPIO_ACTIVE_LOW>; /* PF6 */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc1 {
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ bus-width = <4>;
|
|
+ non-removable;
|
|
+ status = "okay";
|
|
+
|
|
+ /*
|
|
+ * Explicitly define the sdio device, so that we can add an ethernet
|
|
+ * alias for it (which e.g. makes u-boot set a mac-address).
|
|
+ */
|
|
+ rtl8189ftv: sdio_wifi@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
+/*
|
|
+&spi0 {
|
|
+ status = "okay";
|
|
+
|
|
+ flash@0 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ compatible = "mxicy,mx25l1606e", "winbond,w25q128";
|
|
+ reg = <0>;
|
|
+ spi-max-frequency = <40000000>;
|
|
+ };
|
|
+};
|
|
+*/
|
|
+
|
|
+&ohci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins_a>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ dr_mode = "peripheral";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ /* USB Type-A ports' VBUS is always on */
|
|
+ usb0_id_det-gpios = <&pio 6 12 GPIO_ACTIVE_HIGH>; /* PG12 */
|
|
+ status = "okay";
|
|
+};
|
|
--- a/board/sunxi/MAINTAINERS
|
|
+++ b/board/sunxi/MAINTAINERS
|
|
@@ -327,6 +327,11 @@ M: Icenowy Zheng <icenowy@aosc.xyz>
|
|
S: Maintained
|
|
F: configs/orangepi_zero_defconfig
|
|
|
|
+ORANGEPI ZERO PLUS BOARD
|
|
+M: Hauke Mehrtens <hauke@hauke-m.de>
|
|
+S: Maintained
|
|
+F: configs/orangepi_zero_plus_defconfig
|
|
+
|
|
ORANGEPI ZERO PLUS 2 BOARD
|
|
M: Jagan Teki <jagan@amarulasolutions.com>
|
|
S: Maintained
|
|
--- /dev/null
|
|
+++ b/configs/orangepi_zero_plus_defconfig
|
|
@@ -0,0 +1,16 @@
|
|
+CONFIG_ARM=y
|
|
+CONFIG_ARCH_SUNXI=y
|
|
+CONFIG_SPL=y
|
|
+CONFIG_MACH_SUN50I_H5=y
|
|
+CONFIG_DRAM_CLK=624
|
|
+CONFIG_DRAM_ZQ=3881977
|
|
+CONFIG_MMC0_CD_PIN="PH13"
|
|
+CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
|
+CONFIG_DEFAULT_DEVICE_TREE="sun50i-h5-orangepi-zero-plus"
|
|
+# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
|
|
+# CONFIG_CMD_FLASH is not set
|
|
+# CONFIG_SPL_DOS_PARTITION is not set
|
|
+# CONFIG_SPL_EFI_PARTITION is not set
|
|
+CONFIG_SUN8I_EMAC=y
|
|
+CONFIG_USB_EHCI_HCD=y
|
|
+CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
|