openwrtv3/target/linux/ar71xx/patches-4.9/818-MIPS-ath79-add-nu801-led-driver.patch
Hauke Mehrtens 7bbf4117c6 ar71xx: Add kernel 4.9 support
This add support for kernel 4.9 to the ar71xx target.
It was compile tested with the generic, NAND and mikrotik subtarget.
Multiple members of the community tested it on their boards and did not
report any major problem so far.

Especially the NAND part received some changes to adapt to the new
kernel APIs. The serial driver hack used for the Arduino Yun was not
ported because the kernel changed there a lot.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
2017-10-11 22:32:39 +02:00

26 lines
931 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -606,6 +606,13 @@ config LEDS_IS31FL32XX
comment "LED driver for blink(1) USB RGB LED is under Special HID drivers (HID_THINGM)"
+config LEDS_NU801
+ tristate "LED driver for NU801 RGB LED"
+ depends on LEDS_CLASS && (ATH79_MACH_MR18 || ATH79_MACH_Z1)
+ help
+ This option enables support for NU801 RGB LED driver chips
+ accessed via GPIO.
+
config LEDS_BLINKM
tristate "LED support for the BlinkM I2C RGB LED"
depends on LEDS_CLASS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -56,6 +56,7 @@ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5
obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
+obj-$(CONFIG_LEDS_NU801) += leds-nu801.o
obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
obj-$(CONFIG_LEDS_NETXBIG) += leds-netxbig.o
obj-$(CONFIG_LEDS_ASIC3) += leds-asic3.o