openwrtv3/target/linux/generic-2.6/patches-2.6.34/970-ocf_kbuild_integration.patch
Hauke Mehrtens 78981f6f3c kernel: refresh patches with 2.6.34-rc4
SVN-Revision: 20999
2010-04-18 18:35:47 +00:00

25 lines
545 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -833,6 +833,8 @@ config CRYPTO_ANSI_CPRNG
ANSI X9.31 A.2.4. Note that this option must be enabled if
CRYPTO_FIPS is selected
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -87,6 +87,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o