b0b289ea45
CVE-2017-8816: NTLM buffer overflow via integer overflow CVE-2017-8817: FTP wildcard out of bounds read CVE-2017-8818: SSL out of buffer access For other bugfixes and changes in 7.57.0 see https://curl.haxx.se/changes.html Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
22 lines
665 B
Diff
22 lines
665 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -156,7 +156,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
bin_SCRIPTS = curl-config
|
|
|
|
SUBDIRS = lib src
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages scripts include docs
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages include
|
|
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
@@ -267,8 +267,8 @@ cygwinbin:
|
|
# We extend the standard install with a custom hook:
|
|
install-data-hook:
|
|
cd include && $(MAKE) install
|
|
- cd docs && $(MAKE) install
|
|
- cd docs/libcurl && $(MAKE) install
|
|
+ #cd docs && $(MAKE) install
|
|
+ #cd docs/libcurl && $(MAKE) install
|
|
|
|
# We extend the standard uninstall with a custom hook:
|
|
uninstall-hook:
|