openwrtv3/tools/mkimage/patches/100-freebsd-compat.patch
Hauke Mehrtens b13e981d72 tools/mkimage: update to version 2018.03
This activates support for fit images and some other new mkimage
features. Some of the patches were applied upstream and could be
removed.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
2018-04-18 23:59:32 +02:00

14 lines
408 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -634,7 +634,10 @@ UBOOTINCLUDE := \
-I$(srctree)/arch/$(ARCH)/include \
-include $(srctree)/include/linux/kconfig.h
-NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ifneq ($(shell uname),FreeBSD)
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+endif
+
CHECKFLAGS += $(NOSTDINC_FLAGS)
# FIX ME