88ba41453d
Refresh patches. Remove upstreamed patches: - backport/080-v4.15-0001-arch-define-weak-abort.patch - backport/081-v4.15-0002-kernel-exit.c-export-abort-to-modules.patch Update patch that no longer applies: pending/493-ubi-set-ROOT_DEV-to-ubiblock-rootfs-if-unset.patch Fixes CVE-2017-8824. Compile-tested: octeon, x86/64. Runtime-tested: octeon, x86/64. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
32 lines
1 KiB
Diff
32 lines
1 KiB
Diff
From: Felix Fietkau <nbd@nbd.name>
|
|
Subject: Upgrade to Linux 2.6.19
|
|
|
|
- Includes large parts of the patch from #1021 by dpalffy
|
|
- Includes RB532 NAND driver changes by n0-1
|
|
|
|
[john@phrozen.org: feix will add this to his upstream queue]
|
|
|
|
lede-commit: bff468813f78f81e36ebb2a3f4354de7365e640f
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
Makefile | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -639,12 +639,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
|
|
-KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,)
|
|
+KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
|
|
else
|
|
ifdef CONFIG_PROFILE_ALL_BRANCHES
|
|
-KBUILD_CFLAGS += -O2 $(call cc-disable-warning,maybe-uninitialized,)
|
|
+KBUILD_CFLAGS += -O2 $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
|
|
endif
|
|
endif
|
|
|