openwrtv3/target/linux/generic-2.6/patches-2.6.22/010-disable_old_squashfs_compatibility.patch
Gabor Juhos 7d8b70a1ec refresh generic 2.6.22 patches
SVN-Revision: 11186
2008-05-18 20:24:13 +00:00

23 lines
809 B
Diff

Index: linux-2.6.22.19/fs/squashfs/Makefile
===================================================================
--- linux-2.6.22.19.orig/fs/squashfs/Makefile
+++ linux-2.6.22.19/fs/squashfs/Makefile
@@ -4,4 +4,3 @@
obj-$(CONFIG_SQUASHFS) += squashfs.o
squashfs-y += inode.o
-squashfs-y += squashfs2_0.o
Index: linux-2.6.22.19/fs/squashfs/squashfs.h
===================================================================
--- linux-2.6.22.19.orig/fs/squashfs/squashfs.h
+++ linux-2.6.22.19/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)