1a53315951
This backports the upstream commit fixing stale references to CONFIG_SUNXI_GMAC which have been later replaced by CONFIG_SUN7I_GMAC. This fixes the designware MAC pinmuxing on e.g: Lamobo R1. Refresh patches while we are at it. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
26 lines
1,010 B
Diff
26 lines
1,010 B
Diff
From cdee74ad13e933631caf7f544c319d8e981c6063 Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Thu, 20 Jul 2017 19:49:25 +0200
|
|
Subject: [PATCH 211/213] Revert "scripts/Makefile.lib: Always have
|
|
...-u-boot.dtsi be able to override"
|
|
|
|
This reverts commit 7452946e7f3742b3ff1cb4a50603e7492aceea88.
|
|
---
|
|
scripts/Makefile.lib | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -306,10 +306,10 @@ $(obj)/%.dtb.S: $(obj)/%.dtb
|
|
|
|
quiet_cmd_dtc = DTC $@
|
|
# Modified for U-Boot
|
|
-# Bring in any U-Boot-specific include at the end of the file
|
|
+# Bring in any U-Boot-specific include after the '/dts-v1/;' header
|
|
cmd_dtc = mkdir -p $(dir ${dtc-tmp}) ; \
|
|
cat $< $(if $(u_boot_dtsi),\
|
|
- | sed "$$ a\#include \"$(u_boot_dtsi)\"") | \
|
|
+ | sed '/^\/ {$$/{x;s%$$%\#include \"$(u_boot_dtsi)\"%;G;}') | \
|
|
$(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) - ; \
|
|
$(DTC) -O dtb -o $@ -b 0 \
|
|
-i $(dir $<) $(DTC_FLAGS) \
|