baad22eed3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
24 lines
953 B
Diff
24 lines
953 B
Diff
From 9136b739f4ecc714db0431a3e0f4f4d9b12ab670 Mon Sep 17 00:00:00 2001
|
|
From: Dave Stevenson <dave.stevenson@raspberrypi.org>
|
|
Date: Mon, 13 Feb 2017 13:11:41 +0000
|
|
Subject: [PATCH] BCM2835-V4L2: Correctly denote key frames in encoded data
|
|
|
|
Forward MMAL key frame flags to the V4L2 buffers.
|
|
|
|
Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
|
|
---
|
|
drivers/media/platform/bcm2835/bcm2835-camera.c | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/drivers/media/platform/bcm2835/bcm2835-camera.c
|
|
+++ b/drivers/media/platform/bcm2835/bcm2835-camera.c
|
|
@@ -413,6 +413,9 @@ static void buffer_cb(struct vchiq_mmal_
|
|
dev->capture.last_timestamp = buf->vb.vb2_buf.timestamp;
|
|
|
|
vb2_set_plane_payload(&buf->vb.vb2_buf, 0, length);
|
|
+ if (mmal_flags & MMAL_BUFFER_HEADER_FLAG_KEYFRAME)
|
|
+ buf->vb.flags |= V4L2_BUF_FLAG_KEYFRAME;
|
|
+
|
|
v4l2_dbg(1, bcm2835_v4l2_debug, &dev->v4l2_dev,
|
|
"Buffer has ts %llu",
|
|
dev->capture.last_timestamp);
|