baad22eed3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
33 lines
1 KiB
Diff
33 lines
1 KiB
Diff
From e36583656552b7827a1b9d513ec39e95efa7ce8d Mon Sep 17 00:00:00 2001
|
|
From: Matthias Reichl <hias@horus.com>
|
|
Date: Sun, 22 Jan 2017 12:49:36 +0100
|
|
Subject: [PATCH] config: Enable regulator support
|
|
|
|
Signed-off-by: Matthias Reichl <hias@horus.com>
|
|
---
|
|
arch/arm/configs/bcm2709_defconfig | 2 ++
|
|
arch/arm/configs/bcmrpi_defconfig | 2 ++
|
|
2 files changed, 4 insertions(+)
|
|
|
|
--- a/arch/arm/configs/bcm2709_defconfig
|
|
+++ b/arch/arm/configs/bcm2709_defconfig
|
|
@@ -664,6 +664,8 @@ CONFIG_STMPE_SPI=y
|
|
CONFIG_MFD_ARIZONA_I2C=m
|
|
CONFIG_MFD_ARIZONA_SPI=m
|
|
CONFIG_MFD_WM5102=y
|
|
+CONFIG_REGULATOR=y
|
|
+CONFIG_REGULATOR_FIXED_VOLTAGE=m
|
|
CONFIG_MEDIA_SUPPORT=m
|
|
CONFIG_MEDIA_CAMERA_SUPPORT=y
|
|
CONFIG_MEDIA_ANALOG_TV_SUPPORT=y
|
|
--- a/arch/arm/configs/bcmrpi_defconfig
|
|
+++ b/arch/arm/configs/bcmrpi_defconfig
|
|
@@ -658,6 +658,8 @@ CONFIG_STMPE_SPI=y
|
|
CONFIG_MFD_ARIZONA_I2C=m
|
|
CONFIG_MFD_ARIZONA_SPI=m
|
|
CONFIG_MFD_WM5102=y
|
|
+CONFIG_REGULATOR=y
|
|
+CONFIG_REGULATOR_FIXED_VOLTAGE=m
|
|
CONFIG_MEDIA_SUPPORT=m
|
|
CONFIG_MEDIA_CAMERA_SUPPORT=y
|
|
CONFIG_MEDIA_ANALOG_TV_SUPPORT=y
|