baad22eed3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
20 lines
775 B
Diff
20 lines
775 B
Diff
From 341bc67d361def1f23a96c512ab6bc39f32b3601 Mon Sep 17 00:00:00 2001
|
|
From: Aaron Shaw <shawaj@gmail.com>
|
|
Date: Tue, 10 Jan 2017 16:05:41 +0000
|
|
Subject: [PATCH] Add driver_name property
|
|
|
|
Add driver name property for use with 5.1 passthrough audio in LibreElec and other Kodi based OSs
|
|
---
|
|
sound/soc/bcm/justboom-dac.c | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
--- a/sound/soc/bcm/justboom-dac.c
|
|
+++ b/sound/soc/bcm/justboom-dac.c
|
|
@@ -98,6 +98,7 @@ static struct snd_soc_dai_link snd_rpi_j
|
|
/* audio machine driver */
|
|
static struct snd_soc_card snd_rpi_justboom_dac = {
|
|
.name = "snd_rpi_justboom_dac",
|
|
+ .driver_name = "JustBoomDac",
|
|
.owner = THIS_MODULE,
|
|
.dai_link = snd_rpi_justboom_dac_dai,
|
|
.num_links = ARRAY_SIZE(snd_rpi_justboom_dac_dai),
|