7e1e29de75
Runtime-tested on: - Pine64 (A64) - Orange Pi 2 (H3) - Bananapro (A20) - Olimex A20-Micro (A20) - Pcduino v3 (A20) - Pcduino v2 (A10) Compile-tested on: - all A8/A7/A53 boards Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
28 lines
909 B
Diff
28 lines
909 B
Diff
From def280c4792262a368c8861312dc6b376181021f Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Mon, 1 Jan 2018 23:10:56 +0100
|
|
Subject: sunxi: deactivate binman
|
|
|
|
Use the old way to generate the images instead of binman.
|
|
binman needs python with swig to avoid this host tool dependency use the
|
|
old way of generating images.
|
|
---
|
|
Makefile | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1144,9 +1144,10 @@ u-boot-x86-16bit.bin: u-boot FORCE
|
|
endif
|
|
|
|
ifneq ($(CONFIG_ARCH_SUNXI),)
|
|
-u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb \
|
|
- checkbinman FORCE
|
|
- $(call if_changed,binman)
|
|
+OBJCOPYFLAGS_u-boot-sunxi-with-spl.bin = -I binary -O binary \
|
|
+ --pad-to=$(CONFIG_SPL_PAD_TO) --gap-fill=0xff
|
|
+u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img FORCE
|
|
+ $(call if_changed,pad_cat)
|
|
endif
|
|
|
|
ifneq ($(CONFIG_TEGRA),)
|