openwrtv3/target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch
Imre Kaloz 2f4fa6de74 refresh generic 2.6.22 patches
SVN-Revision: 11498
2008-06-16 12:40:48 +00:00

12 lines
352 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -507,6 +507,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)