7e82418372
Update to the latest version of iproute2; see https://lwn.net/Articles/756991/ for a full overview of the changes in 4.17. Remove upstream patch 002-json_print-fix-hidden-64-bit-type-promotion. Backport upstream patch 001-rdma-sync-some-IP-headers-with-glibc fixing rdma compile issue. At the same time re-organize patch numbering so the OpenWRT specific patches start at 100. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
11 lines
379 B
Diff
11 lines
379 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -54,7 +54,7 @@ HOSTCC ?= $(CC)
|
|
DEFINES += -D_GNU_SOURCE
|
|
# Turn on transparent support for LFS
|
|
DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
|
-CCOPTS = -O2
|
|
+CCOPTS = -O2 $(EXTRA_CCOPTS)
|
|
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
|
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
|
|
|