139f99c058
Changes compared to GCC 7.x 001-revert_register_mode_search.patch dropped The underlying issue is described at the end of https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58139 It is fixed by the upstream commit:3fa2798aa8
020-PR-libstdc-81797-Add-.NOTPARALLEL-to-include-Makefil.patch dropped due to already upstream 100-PR-rtl-optimization-83496.patch dropped due to already upstream 910-mbsd_multi.patch modified to fix ambiguous overloaded inform() call error gcc/input.h header: define UNKNOWN_LOCATION ((source_location) 0) - inform (0, "someone does not honour COPTS correctly, passed %d times", - honour_copts); + inform (UNKNOWN_LOCATION, "someone does not honour COPTS correctly, passed %d times", + honour_copts); 940-no-clobber-stamp-bits.patch dropped due to fixed upstream by another way upstream commit:87b2d547f8
950-cpp_file_path_translation.patch dropped, Both -fmacro-prefix-map and -ffile-prefix-map are added to gcc 8.1.0, if I understand it correctly, we should use -fmacro-prefix-map usage: -fmacro-prefix-map=@var{old}=@var{new} upstream commit:859b51f836
-iremap exists as a flag for a long time, for backward compatibility, I think we should keep the variable name unchanged but change its value in rules.mk for gcc 8.x and higher. Compile and run tested on x86_64 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
44 lines
1.4 KiB
Diff
44 lines
1.4 KiB
Diff
commit c96312958c0621e72c9b32da5bc224ffe2161384
|
|
Author: Felix Fietkau <nbd@openwrt.org>
|
|
Date: Mon Oct 19 23:26:09 2009 +0000
|
|
|
|
gcc: create a proper libgcc_pic.a static library for relinking (4.3.3+ for now, backport will follow)
|
|
|
|
SVN-Revision: 18086
|
|
|
|
--- a/libgcc/Makefile.in
|
|
+++ b/libgcc/Makefile.in
|
|
@@ -923,11 +923,12 @@ $(libgcov-driver-objects): %$(objext): $
|
|
|
|
# Static libraries.
|
|
libgcc.a: $(libgcc-objects)
|
|
+libgcc_pic.a: $(libgcc-s-objects)
|
|
libgcov.a: $(libgcov-objects)
|
|
libunwind.a: $(libunwind-objects)
|
|
libgcc_eh.a: $(libgcc-eh-objects)
|
|
|
|
-libgcc.a libgcov.a libunwind.a libgcc_eh.a:
|
|
+libgcc.a libgcov.a libunwind.a libgcc_eh.a libgcc_pic.a:
|
|
-rm -f $@
|
|
|
|
objects="$(objects)"; \
|
|
@@ -948,7 +949,7 @@ all: libunwind.a
|
|
endif
|
|
|
|
ifeq ($(enable_shared),yes)
|
|
-all: libgcc_eh.a libgcc_s$(SHLIB_EXT)
|
|
+all: libgcc_eh.a libgcc_pic.a libgcc_s$(SHLIB_EXT)
|
|
ifneq ($(LIBUNWIND),)
|
|
all: libunwind$(SHLIB_EXT)
|
|
libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_EXT)
|
|
@@ -1154,6 +1155,10 @@ install-shared:
|
|
chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
|
|
$(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a
|
|
|
|
+ $(INSTALL_DATA) libgcc_pic.a $(mapfile) $(DESTDIR)$(inst_libdir)/
|
|
+ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_pic.a
|
|
+ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_pic.a
|
|
+
|
|
$(subst @multilib_dir@,$(MULTIDIR),$(subst \
|
|
@shlib_base_name@,libgcc_s,$(subst \
|
|
@shlib_slibdir_qual@,$(MULTIOSSUBDIR),$(SHLIB_INSTALL))))
|