f2135e7811
This patch 220-add-sunxi50i-nanopi-neo-plus2.patch was merged upstream. The u-boot-sunxi-with-spl.bin is now also created for the ARM64 sunxi boards by U-Boot itself, no need to do it manually any more. This was tested on a H2+ Orange Pi R1 and a H5 Orange Pi Zero Plus. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From def280c4792262a368c8861312dc6b376181021f Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Mon, 1 Jan 2018 23:10:56 +0100
|
|
Subject: sunxi: deactivate binman
|
|
|
|
Use the old way to generate the images instead of binman.
|
|
binman needs python with swig to avoid this host tool dependency use the
|
|
old way of generating images.
|
|
---
|
|
Makefile | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1215,8 +1215,10 @@ endif
|
|
|
|
ifneq ($(CONFIG_ARCH_SUNXI),)
|
|
ifeq ($(CONFIG_ARM64),)
|
|
-u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb FORCE
|
|
- $(call if_changed,binman)
|
|
+OBJCOPYFLAGS_u-boot-sunxi-with-spl.bin = -I binary -O binary \
|
|
+ --pad-to=$(CONFIG_SPL_PAD_TO) --gap-fill=0xff
|
|
+u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img FORCE
|
|
+ $(call if_changed,pad_cat)
|
|
else
|
|
u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.itb FORCE
|
|
$(call if_changed,cat)
|
|
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -711,7 +711,6 @@ config ARCH_SOCFPGA
|
|
|
|
config ARCH_SUNXI
|
|
bool "Support sunxi (Allwinner) SoCs"
|
|
- select BINMAN
|
|
select CMD_GPIO
|
|
select CMD_MMC if MMC
|
|
select CMD_USB if DISTRO_DEFAULTS
|