1246dce0b3
Patches created from tree: git@github.com:danielschwierzeck/u-boot-lantiq.git v2013.10..u-boot-lantiq-v2013.10-openwrt4 Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com> SVN-Revision: 40482
37 lines
1.4 KiB
Diff
37 lines
1.4 KiB
Diff
From 7361581a1baaec43058f5b9350c32c7ac4e58064 Mon Sep 17 00:00:00 2001
|
|
From: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
|
|
Date: Mon, 12 Aug 2013 00:11:16 +0200
|
|
Subject: MIPS: vrx200: add NAND SPL support
|
|
|
|
Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
|
|
|
|
diff --git a/arch/mips/cpu/mips32/vrx200/config.mk b/arch/mips/cpu/mips32/vrx200/config.mk
|
|
index 442156a..b0fc882 100644
|
|
--- a/arch/mips/cpu/mips32/vrx200/config.mk
|
|
+++ b/arch/mips/cpu/mips32/vrx200/config.mk
|
|
@@ -27,4 +27,9 @@ ALL-y += $(obj)u-boot.ltq.norspl
|
|
ALL-$(CONFIG_SPL_LZO_SUPPORT) += $(obj)u-boot.ltq.lzo.norspl
|
|
ALL-$(CONFIG_SPL_LZMA_SUPPORT) += $(obj)u-boot.ltq.lzma.norspl
|
|
endif
|
|
+ifdef CONFIG_SYS_BOOT_NANDSPL
|
|
+ALL-y += $(obj)u-boot.ltq.nandspl
|
|
+ALL-$(CONFIG_SPL_LZO_SUPPORT) += $(obj)u-boot.ltq.lzo.nandspl
|
|
+ALL-$(CONFIG_SPL_LZMA_SUPPORT) += $(obj)u-boot.ltq.lzma.nandspl
|
|
+endif
|
|
endif
|
|
diff --git a/arch/mips/include/asm/arch-vrx200/config.h b/arch/mips/include/asm/arch-vrx200/config.h
|
|
index 88ef256..4ec6092 100644
|
|
--- a/arch/mips/include/asm/arch-vrx200/config.h
|
|
+++ b/arch/mips/include/asm/arch-vrx200/config.h
|
|
@@ -164,7 +164,7 @@
|
|
#define CONFIG_SYS_TEXT_BASE 0xB0000000
|
|
#endif
|
|
|
|
-#if defined(CONFIG_SYS_BOOT_SFSPL)
|
|
+#if defined(CONFIG_SYS_BOOT_SFSPL) || defined(CONFIG_SYS_BOOT_NANDSPL)
|
|
#define CONFIG_SYS_TEXT_BASE 0x80100000
|
|
#define CONFIG_SPL_TEXT_BASE 0xBE220000
|
|
#endif
|
|
--
|
|
1.8.3.2
|
|
|