openwrtv3/target/linux
Gabor Juhos 668e529220 generic: fix gc_sections patch
Due to the patch, essential '.data..*' sections are merged
into the '.data' section:

  --- vmlinux.good.sect   2013-02-01 23:49:16.000000000 +0100
  +++ vmlinux.bad.sect    2013-02-01 23:49:02.000000000 +0100
  @@ -1,5 +1,5 @@

  -vmlinux.good:     file format elf32-powerpc
  +vmlinux.bad:     file format elf32-powerpc

   Sections:
   Idx Name          Size      VMA       LMA       File off  Algn
  @@ -53,43 +53,35 @@
                     CONTENTS, ALLOC, LOAD, READONLY, DATA
    24 .machine.desc 00000460  c04e1000  004e1000  004f1000  2**2
                     CONTENTS, ALLOC, LOAD, DATA
  - 25 .data         0000f6a0  c04e2000  004e2000  004f2000  2**12
  + 25 .data         0001635c  c04e2000  004e2000  004f2000  2**12
                     CONTENTS, ALLOC, LOAD, DATA
  - 26 .data..init_task 00002000  c04f2000  004f2000  00502000  2**3
  -                  CONTENTS, ALLOC, LOAD, DATA
  - 27 .data..page_aligned 00002000  c04f4000  004f4000  00504000  2**12
  -                  CONTENTS, ALLOC, LOAD, DATA
  - 28 .data..cacheline_aligned 00000c00  c04f6000  004f6000  00506000
    2**5
  -                  CONTENTS, ALLOC, LOAD, DATA
  - 29 .data..read_mostly 000015e0  c04f6c00  004f6c00  00506c00  2**3
  -                  CONTENTS, ALLOC, LOAD, DATA
  - 30 .sbss         000002e0  c04f9000  004f9000  005081e0  2**3
  + 26 .sbss         000002e0  c04fa000  004fa000  0050835c  2**3
  <...>

This causes boot hang on powerpc. Modify the patch to
ensure that the kernel specific '.data..*' sections
remain separate.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 35447
2013-02-02 09:30:47 +00:00
..
adm5120 kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
adm8668 create Linksys WRTU54G-TM profile 2012-12-07 18:02:31 +00:00
amazon remove common symbols from 3.3 configs 2012-11-29 15:21:35 +00:00
ar7 all targets: use numerically prefixed uci-defaults file names to better control order of execution 2013-01-18 12:42:53 +00:00
ar71xx ar71xx: fix mac address calculation on the OpenMesh MR600 2013-02-02 08:47:41 +00:00
at91 target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
atheros all targets: use numerically prefixed uci-defaults file names to better control order of execution 2013-01-18 12:42:53 +00:00
au1000 remove common symbols from 3.6 configs 2012-11-29 15:21:41 +00:00
avr32 remove common symbols from 3.3 configs 2012-11-29 15:21:35 +00:00
brcm47xx brcm47xx: load pps_core and ptp before tg3 to make the interface available for failsafe. 2013-01-27 21:48:28 +00:00
brcm63xx bcm63xx: replace kmod-switch with swconfig in default package set 2013-01-30 00:19:21 +00:00
brcm2708 target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
cns3xxx target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
cns21xx kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
cobalt remove common symbols from 3.3 configs 2012-11-29 15:21:35 +00:00
coldfire target: refresh all target configs with kconfig.pl 2012-10-29 10:11:05 +00:00
ep93xx target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
gemini target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
generic generic: fix gc_sections patch 2013-02-02 09:30:47 +00:00
imx21 target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
iop32x target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
ixp4xx target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
kirkwood all targets: use numerically prefixed uci-defaults file names to better control order of execution 2013-01-18 12:42:53 +00:00
lantiq kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
leon move patches to patches-2.6.36 2012-11-16 16:32:55 +00:00
malta kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
mcs814x all targets: use numerically prefixed uci-defaults file names to better control order of execution 2013-01-18 12:42:53 +00:00
mpc52xx target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
mpc83xx refresh kernel configs 2013-02-01 17:28:40 +00:00
mpc85xx mpc85xx: nuke 3.3 support 2013-02-01 17:49:56 +00:00
mvebu mvebu: update to 3.8-rc4 2013-01-24 17:04:46 +00:00
octeon move i2c driver to target modules.mk 2012-07-25 15:50:13 +00:00
omap4 target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
omap24xx remove common symbols from 3.3 configs 2012-11-29 15:21:35 +00:00
omap35xx target: refresh all target configs with kconfig.pl 2012-10-29 10:11:05 +00:00
orion all targets: use numerically prefixed uci-defaults file names to better control order of execution 2013-01-18 12:42:53 +00:00
ppc40x kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
ppc44x kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
pxa target: enable XZ BCJ decompressor code after r35097 2013-01-14 16:34:25 +00:00
ramips refresh kernel configs 2013-02-01 17:28:40 +00:00
rb532 kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
realview kernel: clean up crypto kconfig options on 3.8 2013-01-27 17:49:09 +00:00
sibyte remove common symbols from 3.3 configs 2012-11-29 15:21:35 +00:00
sparc kernel: update linux 3.6 to 3.6.11 2012-12-18 14:41:16 +00:00
uml kernel: update linux 3.6 to 3.6.11 2012-12-18 14:41:16 +00:00
x86 kernel: update linux 3.7 to 3.7.5 2013-01-29 18:29:45 +00:00
xburst kernel: add missing USB configuration symbols after r34501 2012-12-07 11:01:53 +00:00
Makefile Add kernel_nconfig make target 2010-08-06 21:36:35 +00:00