openwrtv3/package/madwifi/patches/476-3.0_detection_fix.patch
Hauke Mehrtens e8974127fb madwifi: Fix linux 3.0 detection
Allows madwifi to be built against linux 3.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>

SVN-Revision: 27188
2011-06-15 21:17:17 +00:00

25 lines
714 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -155,13 +155,15 @@ unload:
configcheck:
@echo -n "Checking kernel configuration... "
- @# check version of kernel
- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
- echo "FAILED"; \
- echo "Only kernel versions 2.4.x and above are supported."; \
- echo "You have $(KERNELRELEASE)."; \
- exit 1; \
- }
+ @# check kernel version
+ @case $(KERNELRELEASE) in \
+ 2.[456].*) ;; \
+ [3-9].*) ;; \
+ *) echo "FAILED"; \
+ echo "Only kernel versions 2.4.x and above are supported."; \
+ echo "You have $(KERNELRELEASE)."; \
+ exit 1 ;; \
+ esac
@# check kernel configuration
@if [ -z "$(CONFIG_SYSCTL)" ]; then \