openwrtv3/target/linux/generic/patches-3.0/940-ocf_kbuild_integration.patch
Hauke Mehrtens 235e331987 linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>

SVN-Revision: 27191
2011-06-15 21:31:01 +00:00

20 lines
480 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -860,3 +860,6 @@ config CRYPTO_USER_API_SKCIPHER
source "drivers/crypto/Kconfig"
endif # if CRYPTO
+
+source "crypto/ocf/Kconfig"
+
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -89,6 +89,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+obj-$(CONFIG_OCF_OCF) += ocf/
+
#
# generic algorithms and the async_tx api
#