openwrtv3/target/linux/ifxmips/patches/110-drivers.patch
John Crispin 5eda098fa7 move files, rename defines for ifxmips
SVN-Revision: 11565
2008-06-22 20:40:36 +00:00

115 lines
4.8 KiB
Diff

Index: linux-2.6.25.7/drivers/char/Makefile
===================================================================
--- linux-2.6.25.7.orig/drivers/char/Makefile 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/char/Makefile 2008-06-18 00:36:56.000000000 +0200
@@ -113,6 +113,11 @@
obj-$(CONFIG_JS_RTC) += js-rtc.o
js-rtc-y = rtc.o
+obj-$(CONFIG_IFXMIPS_LED) += ifxmips_led.o
+obj-$(CONFIG_IFXMIPS_SSC) += ifxmips_ssc.o
+obj-$(CONFIG_IFXMIPS_EEPROM) += ifxmips_eeprom.o
+obj-$(CONFIG_IFXMIPS_MEI) += ifxmips_mei_core.o
+
# Files generated that shall be removed upon make clean
clean-files := consolemap_deftbl.c defkeymap.c
Index: linux-2.6.25.7/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.25.7.orig/drivers/mtd/maps/Makefile 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/mtd/maps/Makefile 2008-06-18 00:36:56.000000000 +0200
@@ -68,3 +68,4 @@
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
Index: linux-2.6.25.7/drivers/net/Kconfig
===================================================================
--- linux-2.6.25.7.orig/drivers/net/Kconfig 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/net/Kconfig 2008-06-18 00:36:56.000000000 +0200
@@ -351,6 +351,12 @@
source "drivers/net/arm/Kconfig"
+config IFXMIPS_MII0
+ tristate "Infineon IFXMips eth0 driver"
+ depends on IFXMIPS
+ help
+ Support for the MII0 inside the IFXMips SOC
+
config AX88796
tristate "ASIX AX88796 NE2000 clone support"
depends on ARM || MIPS || SUPERH
Index: linux-2.6.25.7/drivers/serial/Kconfig
===================================================================
--- linux-2.6.25.7.orig/drivers/serial/Kconfig 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/serial/Kconfig 2008-06-18 00:36:56.000000000 +0200
@@ -1327,6 +1327,14 @@
Currently, only 8250 compatible ports are supported, but
others can easily be added.
+config SERIAL_IFXMIPS
+ bool "IFXMips serial driver"
+ depends on IFXMIPS
+ select SERIAL_CORE
+ select SERIAL_CORE_CONSOLE
+ help
+ Driver for the ifxmipss built in ASC hardware
+
config SERIAL_QE
tristate "Freescale QUICC Engine serial port support"
depends on QUICC_ENGINE
Index: linux-2.6.25.7/drivers/serial/Makefile
===================================================================
--- linux-2.6.25.7.orig/drivers/serial/Makefile 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/serial/Makefile 2008-06-18 00:36:56.000000000 +0200
@@ -66,4 +66,5 @@
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
Index: linux-2.6.25.7/drivers/watchdog/Makefile
===================================================================
--- linux-2.6.25.7.orig/drivers/watchdog/Makefile 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/watchdog/Makefile 2008-06-18 00:36:56.000000000 +0200
@@ -96,6 +96,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
# PARISC Architecture
Index: linux-2.6.25.7/drivers/net/Makefile
===================================================================
--- linux-2.6.25.7.orig/drivers/net/Makefile 2008-06-18 00:34:41.000000000 +0200
+++ linux-2.6.25.7/drivers/net/Makefile 2008-06-18 00:36:56.000000000 +0200
@@ -254,3 +254,4 @@
obj-$(CONFIG_NETXEN_NIC) += netxen/
obj-$(CONFIG_NIU) += niu.o
obj-$(CONFIG_VIRTIO_NET) += virtio_net.o
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
Index: linux-2.6.25.7/drivers/crypto/Kconfig
===================================================================
--- linux-2.6.25.7.orig/drivers/crypto/Kconfig 2008-06-18 18:10:24.000000000 +0200
+++ linux-2.6.25.7/drivers/crypto/Kconfig 2008-06-18 18:11:46.000000000 +0200
@@ -9,6 +9,9 @@
If you say N, all options in this submenu will be skipped and disabled.
if CRYPTO_HW
+config CRYPTO_DEV_IFXMIPS
+ tristate "Support for IFXMIPS Data Encryption Unit"
+ depends on IFXMIPS
config CRYPTO_DEV_PADLOCK
tristate "Support for VIA PadLock ACE"
Index: linux-2.6.25.7/drivers/crypto/Makefile
===================================================================
--- linux-2.6.25.7.orig/drivers/crypto/Makefile 2008-06-18 18:09:30.000000000 +0200
+++ linux-2.6.25.7/drivers/crypto/Makefile 2008-06-18 18:10:18.000000000 +0200
@@ -2,3 +2,4 @@
obj-$(CONFIG_CRYPTO_DEV_PADLOCK_SHA) += padlock-sha.o
obj-$(CONFIG_CRYPTO_DEV_GEODE) += geode-aes.o
obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o
+obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o