openwrtv3/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch
2010-01-20 09:30:36 +00:00

27 lines
845 B
Diff

--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -146,4 +146,14 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module
will be called mdio-gpio.
+config RTL8366_SMI
+ tristate "Support for RTL8366 switch via SMI interface"
+ depends on GENERIC_GPIO
+
+config RTL8366_SMI_DEBUG_FS
+ bool "RTL8366S driver DEBUG_FS support"
+ depends on RTL8366_SMI
+ depends on DEBUG_FS
+ default n
+
endif # PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -20,6 +20,7 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_MICREL) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o