openwrtv3/target/linux/generic/patches-2.6.38/970-ocf_kbuild_integration.patch
Imre Kaloz c700e57cc7 preliminary 2.6.38 support
SVN-Revision: 25057
2011-01-21 17:52:22 +00:00

20 lines
480 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -870,3 +870,6 @@ config CRYPTO_USER_API_SKCIPHER
source "drivers/crypto/Kconfig"
endif # if CRYPTO
+
+source "crypto/ocf/Kconfig"
+
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -89,6 +89,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+obj-$(CONFIG_OCF_OCF) += ocf/
+
#
# generic algorithms and the async_tx api
#