openwrtv3/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
John Crispin 53c474abbd ath79: add new OF only target for QCA MIPS silicon
This target aims to replace ar71xx mid-term. The big part that is still
missing is making the MMIO/AHB wifi work using OF. NAND and mikrotik
subtargets will follow.

Signed-off-by: John Crispin <john@phrozen.org>
2018-05-07 08:06:51 +02:00

29 lines
1.1 KiB
Diff

Index: linux-4.14.18/drivers/mtd/Kconfig
===================================================================
--- linux-4.14.18.orig/drivers/mtd/Kconfig
+++ linux-4.14.18/drivers/mtd/Kconfig
@@ -194,6 +194,12 @@ config MTD_MYLOADER_PARTS
You will still need the parsing functions to be called by the driver
for your particular device. It won't happen automatically.
+config MTD_TPLINK_PARTS
+ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
+ depends on ATH79
+ ---help---
+ TBD.
+
comment "User Modules And Translation Layers"
#
Index: linux-4.14.18/drivers/mtd/Makefile
===================================================================
--- linux-4.14.18.orig/drivers/mtd/Makefile
+++ linux-4.14.18/drivers/mtd/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
obj-y += parsers/
+obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o