openwrtv3/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
Jonas Gorski 46a69e96a4 xtables-addons: update to 2.7 to fix compilation with 4.1
Also drop the configure (not .ac) patch part as autoreconf will
overwrite it anyway with a newly generated version.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
Acked-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 46385
2015-07-15 14:41:45 +00:00

11 lines
392 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
if test -n "$kbuilddir"; then
AC_MSG_CHECKING([kernel version that we will build against])
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
kmajor="${krel%%[[^0-9]]*}";
kmajor="$(($kmajor+0))";
krel="${krel:${#kmajor}}";