openwrtv3/target/linux/orion/patches/200-dt2_board_support.patch
Hauke Mehrtens e23f27b72d orion: Update kernel to 3.10.44
Update the kernel of the orion target to version 3.10.44.
Refresh orion config and patches to match the changes in the kernel

Tested on WRT350N-v2 device.

Signed-off-by: Maarten Bezemer <maarten.bezemer@gmail.com>
[run make kernel_oldconfig, fold a01-dt2-fixes-for-3.3.patch into dt2-setup.c,
 make dt2-setup.c compile, fix harddisk subprofile]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 41765
2014-07-20 09:42:14 +00:00

26 lines
934 B
Diff

--- a/arch/arm/mach-orion5x/Kconfig
+++ b/arch/arm/mach-orion5x/Kconfig
@@ -23,6 +23,13 @@ config MACH_RD88F5182
Say 'Y' here if you want your kernel to support the
Marvell Orion-NAS (88F5182) RD2
+config MACH_DT2
+ bool "Freecom DataTank Gateway"
+ select I2C_BOARDINFO
+ help
+ Say 'Y' here if you want your kernel to support the
+ Freecom DataTank Gateway
+
config MACH_KUROBOX_PRO
bool "KuroBox Pro"
select I2C_BOARDINFO
--- a/arch/arm/mach-orion5x/Makefile
+++ b/arch/arm/mach-orion5x/Makefile
@@ -17,6 +17,7 @@ obj-$(CONFIG_MACH_BIGDISK) += d2net-setu
obj-$(CONFIG_MACH_NET2BIG) += net2big-setup.o
obj-$(CONFIG_MACH_MSS2) += mss2-setup.o
obj-$(CONFIG_MACH_WNR854T) += wnr854t-setup.o
+obj-$(CONFIG_MACH_DT2) += dt2-setup.o
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o