e2aa0c3f8b
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
28 lines
787 B
Diff
28 lines
787 B
Diff
--- a/drivers/net/ethernet/atheros/Kconfig
|
|
+++ b/drivers/net/ethernet/atheros/Kconfig
|
|
@@ -5,7 +5,7 @@
|
|
config NET_VENDOR_ATHEROS
|
|
bool "Atheros devices"
|
|
default y
|
|
- depends on PCI
|
|
+ depends on (PCI || ATH79)
|
|
---help---
|
|
If you have a network (Ethernet) card belonging to this class, say Y.
|
|
|
|
@@ -78,4 +78,6 @@ config ALX
|
|
To compile this driver as a module, choose M here. The module
|
|
will be called alx.
|
|
|
|
+source drivers/net/ethernet/atheros/ag71xx/Kconfig
|
|
+
|
|
endif # NET_VENDOR_ATHEROS
|
|
--- a/drivers/net/ethernet/atheros/Makefile
|
|
+++ b/drivers/net/ethernet/atheros/Makefile
|
|
@@ -3,6 +3,7 @@
|
|
# Makefile for the Atheros network device drivers.
|
|
#
|
|
|
|
+obj-$(CONFIG_AG71XX) += ag71xx/
|
|
obj-$(CONFIG_ATL1) += atlx/
|
|
obj-$(CONFIG_ATL2) += atlx/
|
|
obj-$(CONFIG_ATL1E) += atl1e/
|