0cda4af005
Refreshed all patches. Added new patch: - 192-Revert-ubifs-xattr-Don-t-operate-on-deleted-inodes.patch This fixes a bug introduced in upstream 4.14.68 which caused targets using ubifs to produce file-system errors on boot, rendering them useless. Compile-tested on: cns3xxx, imx6, x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
19 lines
728 B
Diff
19 lines
728 B
Diff
--- a/drivers/mtd/parsers/Makefile
|
|
+++ b/drivers/mtd/parsers/Makefile
|
|
@@ -1 +1,2 @@
|
|
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
|
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
|
--- a/drivers/mtd/parsers/Kconfig
|
|
+++ b/drivers/mtd/parsers/Kconfig
|
|
@@ -1,3 +1,11 @@
|
|
+config MTD_PARSER_CYBERTAN
|
|
+ tristate "Parser for Cybertan format partitions"
|
|
+ depends on MTD && (ATH79 || COMPILE_TEST)
|
|
+ help
|
|
+ Cybertan has a proprietory header than encompasses a Broadcom trx
|
|
+ header. This driver will parse the header and take care of the
|
|
+ special offsets that result in the extra headers.
|
|
+
|
|
config MTD_PARSER_TRX
|
|
tristate "Parser for TRX format partitions"
|
|
depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)
|