e553dfc356
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
24 lines
978 B
Diff
24 lines
978 B
Diff
Index: linux-3.14.18/drivers/clocksource/Kconfig
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/clocksource/Kconfig
|
|
+++ linux-3.14.18/drivers/clocksource/Kconfig
|
|
@@ -140,3 +140,9 @@ config VF_PIT_TIMER
|
|
bool
|
|
help
|
|
Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
|
|
+
|
|
+config CLKSRC_RPS_TIMER
|
|
+ def_bool y if ARCH_OXNAS
|
|
+ select CLKSRC_MMIO
|
|
+ help
|
|
+ This option enables support for the oxnas rps timers.
|
|
Index: linux-3.14.18/drivers/clocksource/Makefile
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/clocksource/Makefile
|
|
+++ linux-3.14.18/drivers/clocksource/Makefile
|
|
@@ -37,3 +37,5 @@ obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arc
|
|
obj-$(CONFIG_ARM_GLOBAL_TIMER) += arm_global_timer.o
|
|
obj-$(CONFIG_CLKSRC_METAG_GENERIC) += metag_generic.o
|
|
obj-$(CONFIG_ARCH_HAS_TICK_BROADCAST) += dummy_timer.o
|
|
+
|
|
+obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
|