openwrtv3/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
John Crispin 6944a95091 oxnas: move gmac soc glue from mach to stmmac driver
Still a lot of kernel-version ifdef'ery, but imho that's easy to remove
once obsoleted and avoids duplicate code in the meantime.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 47218
2015-10-19 10:09:36 +00:00

25 lines
1 KiB
Diff

--- a/drivers/net/ethernet/stmicro/stmmac/Kconfig
+++ b/drivers/net/ethernet/stmicro/stmmac/Kconfig
@@ -20,7 +20,7 @@ config STMMAC_PLATFORM
---help---
This selects the platform specific bus support for the stmmac driver.
This is the driver used on several SoCs:
- STi, Allwinner, Amlogic Meson, Altera SOCFPGA.
+ STi, Allwinner, Amlogic Meson, Altera SOCFPGA and Oxnas.
If you have a controller with this interface, say Y or M here.
--- a/drivers/net/ethernet/stmicro/stmmac/Makefile
+++ b/drivers/net/ethernet/stmicro/stmmac/Makefile
@@ -5,8 +5,9 @@ stmmac-objs:= stmmac_main.o stmmac_ethto
mmc_core.o stmmac_hwtstamp.o stmmac_ptp.o $(stmmac-y)
obj-$(CONFIG_STMMAC_PLATFORM) += stmmac-platform.o
-stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-sunxi.o \
- dwmac-sti.o dwmac-socfpga.o dwmac-rk.o
+stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-oxnas.o \
+ dwmac-sunxi.o dwmac-sti.o dwmac-socfpga.o \
+ dwmac-rk.o
obj-$(CONFIG_STMMAC_PCI) += stmmac-pci.o
stmmac-pci-objs:= stmmac_pci.o