openwrtv3/package/network/utils/curl/patches/100-check_long_long.patch
Hauke Mehrtens 275ba42c52 curl: 7.36.0 -> 7.38.0
Main changes:
- URL parser: IPv6 zone identifiers are now supported
- cyassl: Use error-ssl.h when available (drop local patch)
- polarssl: support CURLOPT_CAPATH / --capath
- mkhelp: generate code for --disable-manual as well (drop local patch)

Full release notes: http://curl.haxx.se/changes.html

MIPS 34kc binary size:
- 7.36.0 before: 82,539 bytes
- 7.38.0 after: 83,321 bytes

Signed-off-by: Catalin Patulea <cat@vv.carleton.ca>

SVN-Revision: 42517
2014-09-13 20:26:08 +00:00

10 lines
229 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2877,6 +2877,7 @@ CURL_VERIFY_RUNTIMELIBS
AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(long)
+AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(short)
CURL_CONFIGURE_LONG