baad22eed3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
27 lines
991 B
Diff
27 lines
991 B
Diff
From b8ded4dca34feafd33f22eff47d19b17b7dd83f4 Mon Sep 17 00:00:00 2001
|
|
From: Boris Brezillon <boris.brezillon@free-electrons.com>
|
|
Date: Tue, 22 Nov 2016 12:45:28 -0800
|
|
Subject: [PATCH] clk: bcm2835: Fix ->fixed_divider of pllh_aux
|
|
|
|
There is no fixed divider on pllh_aux.
|
|
|
|
Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
|
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
|
|
(cherry picked from commit f2a46926aba1f0c33944901d2420a6a887455ddc)
|
|
---
|
|
drivers/clk/bcm/clk-bcm2835.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/drivers/clk/bcm/clk-bcm2835.c
|
|
+++ b/drivers/clk/bcm/clk-bcm2835.c
|
|
@@ -1607,7 +1607,7 @@ static const struct bcm2835_clk_desc clk
|
|
.a2w_reg = A2W_PLLH_AUX,
|
|
.load_mask = CM_PLLH_LOADAUX,
|
|
.hold_mask = 0,
|
|
- .fixed_divider = 10),
|
|
+ .fixed_divider = 1),
|
|
[BCM2835_PLLH_PIX] = REGISTER_PLL_DIV(
|
|
.name = "pllh_pix",
|
|
.source_pll = "pllh",
|