baad22eed3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
From f9efb72c44da2cce9cceca01c8f6118ec1605c69 Mon Sep 17 00:00:00 2001
|
|
From: Martin Cerveny <M.Cerveny@computer.org>
|
|
Date: Mon, 13 Feb 2017 17:23:47 +0100
|
|
Subject: [PATCH] dwc_otg: fix summarize urb->actual_length for isochronous
|
|
transfers
|
|
|
|
Kernel does not copy input data of ISO transfers to userspace
|
|
if actual_length is set only in ISO transfers and not summarized
|
|
in urb->actual_length. Fixes raspberrypi/linux#903
|
|
---
|
|
drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
--- a/drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c
|
|
+++ b/drivers/usb/host/dwc_otg/dwc_otg_hcd_linux.c
|
|
@@ -334,10 +334,12 @@ static int _complete(dwc_otg_hcd_t * hcd
|
|
int i;
|
|
|
|
urb->error_count = dwc_otg_hcd_urb_get_error_count(dwc_otg_urb);
|
|
+ urb->actual_length = 0;
|
|
for (i = 0; i < urb->number_of_packets; ++i) {
|
|
urb->iso_frame_desc[i].actual_length =
|
|
dwc_otg_hcd_urb_get_iso_desc_actual_length
|
|
(dwc_otg_urb, i);
|
|
+ urb->actual_length += urb->iso_frame_desc[i].actual_length;
|
|
urb->iso_frame_desc[i].status =
|
|
dwc_otg_hcd_urb_get_iso_desc_status(dwc_otg_urb, i);
|
|
}
|