249a9b35e0
Rename the dts file to match the used SoC type and drop the unnecessary KERNEL_INSTALL from the image build code. Remove the fixed rootfs and kernel partitions and create an image with rootfs appended after kernel. Setup a switch portmap matching the hardware and a default network/switch configuration to make make the second lan port working. Use eth0 as lan to have it consistent accross the target. Use the power LED to indicate the boot status. Sort the SoC entries within the dts by address and use dtc labels whenever possible. Signed-off-by: Mathias Kresin <dev@kresin.me> Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
24 lines
756 B
Diff
24 lines
756 B
Diff
From 8f68331e14dff9a101f2d0e1d6bec84a031f27ee Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 9 Mar 2017 11:03:18 +0100
|
|
Subject: [PATCH 69/69] arm: boot: add dts files
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -697,7 +697,11 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8074-dragonboard.dtb \
|
|
qcom-apq8084-ifc6540.dtb \
|
|
qcom-apq8084-mtp.dtb \
|
|
+ qcom-ipq4018-a42.dtb \
|
|
qcom-ipq4019-ap.dk01.1-c1.dtb \
|
|
+ qcom-ipq4019-ap.dk04.1-c1.dtb \
|
|
+ qcom-ipq4019-fritz4040.dtb \
|
|
+ qcom-ipq4029-gl-b1300.dtb \
|
|
qcom-ipq8064-ap148.dtb \
|
|
qcom-msm8660-surf.dtb \
|
|
qcom-msm8960-cdp.dtb \
|