openwrtv3/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch
Florian Fainelli b1ba4c5096 mcs814x: add support for 3.18
Signed-off-by: Florian Fainelli <florian@openwrt.org>

SVN-Revision: 45273
2015-04-04 18:01:07 +00:00

20 lines
688 B
Diff

--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -164,6 +164,10 @@ config RTL8306_PHY
tristate "Driver for Realtek RTL8306S switches"
select SWCONFIG
+config MCS814X_PHY
+ tristate "Driver for the Moschip MCS814x internal PHY"
+ depends on ARCH_MCS814X
+
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -51,3 +51,4 @@ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o
obj-$(CONFIG_MDIO_MOXART) += mdio-moxart.o
obj-$(CONFIG_AMD_XGBE_PHY) += amd-xgbe-phy.o
obj-$(CONFIG_MDIO_BCM_UNIMAC) += mdio-bcm-unimac.o
+obj-$(CONFIG_MCS814X_PHY) += mcs814x.o