openwrtv3/package/mac80211/patches/020-wext-fix.patch
Alexandros C. Couloumbis 186fa51531 mac80211: fix compile issues on 2.6.35
SVN-Revision: 21990
2010-06-30 14:10:41 +00:00

11 lines
403 B
Diff

--- a/scripts/gen-compat-autoconf.sh
+++ b/scripts/gen-compat-autoconf.sh
@@ -192,7 +192,7 @@ if [ -f $KLIB_BUILD/Makefile ]; then
define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS
rm -f $MULT_DEP_FILE
# Kernels >= 2.6.32 can disable WEXT :D
- if [ $SUBLEVEL -le 32 ]; then
+ if [ $SUBLEVEL -le 35 ]; then
define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
fi
fi