openwrtv3/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
Felix Fietkau 1185e645a7 kernel: disable MIPS VDSO by default until the cache issues have been resolved
Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 48802
2016-02-26 09:49:32 +00:00

21 lines
646 B
Diff

Disable MIPS VDSO until the cache issues have been sorted out.
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
--- a/arch/mips/vdso/Makefile
+++ b/arch/mips/vdso/Makefile
@@ -26,11 +26,11 @@ aflags-vdso := $(ccflags-vdso) \
# the comments on that file.
#
ifndef CONFIG_CPU_MIPSR6
- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
- $(warning MIPS VDSO requires binutils >= 2.25)
+# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
+# $(warning MIPS VDSO requires binutils >= 2.25)
obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
ccflags-vdso += -DDISABLE_MIPS_VDSO
- endif
+# endif
endif
# VDSO linker flags.