openwrtv3/target/linux/magicbox/patches/100-cf_slot.patch
Gabor Juhos 014a020b5f update to 2.6.26
SVN-Revision: 12066
2008-08-01 19:34:37 +00:00

36 lines
804 B
Diff

--- a/drivers/ide/ide.c
+++ b/drivers/ide/ide.c
@@ -494,6 +494,9 @@
return -EPERM;
#endif
+#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
+ ide_magicbox_init();
+#endif
}
int set_pio_mode(ide_drive_t *drive, int arg)
--- a/drivers/ide/Kconfig
+++ b/drivers/ide/Kconfig
@@ -928,6 +928,14 @@
If unsure, say N.
+config BLK_DEV_MAGICBOX_IDE
+ bool "MagicBox 2.0 CF IDE support"
+ depends on 4xx && IDE
+ help
+ This option provides support for IDE on MagicBox 2.0 boards.
+
+ If unsure, say N.
+
choice
prompt "Type of MPC8xx IDE interface"
depends on BLK_DEV_MPC8xx_IDE
--- a/drivers/ide/ppc/Makefile
+++ b/drivers/ide/ppc/Makefile
@@ -1,3 +1,4 @@
obj-$(CONFIG_BLK_DEV_IDE_PMAC) += pmac.o
obj-$(CONFIG_BLK_DEV_MPC8xx_IDE) += mpc8xx.o
+obj-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += magicbox_ide.o