lua: honor LDFLAGS
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46036
This commit is contained in:
parent
ca96d1ab3f
commit
feeea1cd28
1 changed files with 11 additions and 0 deletions
11
package/utils/lua/patches/050-honor-cflags.patch
Normal file
11
package/utils/lua/patches/050-honor-cflags.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -56,7 +56,7 @@ $(LUA_A): $(CORE_O) $(LIB_O)
|
||||
$(RANLIB) $@
|
||||
|
||||
$(LUA_SO): $(CORE_O) $(LIB_O)
|
||||
- $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
|
||||
+ $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions $(MYLDFLAGS) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
|
||||
ln -fs $@.$(PKG_VERSION) $@
|
||||
|
||||
|
Loading…
Reference in a new issue